How to avoid Particles System to teleport particles?


#1

Is it possible to not have the particles teleporting inside the bounding box? or removing the bounding box?

on the User Manual the only parameter that seems to control this feature is: WRAP BOUNDS: “World space AABB volume centred on the owner entity’s position. If a particle crosses the boundary of one side of the volume, it teleports to the opposite side. You can use this to make environmental effects like rain by moving a wrapped emitter’s owner entity.”

If I enable this function the particle FX disappears but when I turn it off again the bounding box has adapted his dimensions to the particles life/length. This solution though doesn’t seems to work every time.

Is possible just to remove the bounding box and as consequence the teleporting feature?


#2

Seems a recent version has started wrapping irrespective of whether the wrap flag is on or not…


#3

Heyhey dear Playcanvas-Team,
Im coming from a Unreal-Engine Background and my agency is in need of a Realtime-Engine which is suited vor web develompemt. We think Playcanvas is the way to go.
So we are testing Playcanvas right now.

Sadly the particle system still have the “teleport”-problem, When particles reach the bounding box they are wrapping around. I played now the whole day with the particle system and no checkbox can solve the problem. Can i set the bouding box size via a script maybe?

cheers


#4

Hmm, sad that there is no solution for the problem, so Playcanvas Particle System is sadly still not production ready.