How do I disable this bar?

I already know which file I’m in because it’s on the tab. The bar is repeating information and the way it changes from 2 to 3 lines of code as I scroll is really distracting. How do I turn it off? It doesn’t appear in the Preferences.

Hi @PeteB!

Do you mean the part above the red lines or in between the red lines?

I never seen the part in between the red lines and I don’t understand why I see line 1, 3 and 119.

Its a feature of the Monaco code editor. You should have the same one in VS Code. It just shows which function/method you are currently in. As far as I know, you cannot disable it.

I use the default code editor of PlayCanvas and I don’t see this bar.

It would need exposing in the PlayCanvas Editor via IEditorStickyScrollOptions | Monaco Editor API

1 Like

Maybe @KPal can help with it.