High resolution texture / lights - disappear

Hi folks,
I have two questions, about texture and lightning.
I’m really a noob and playing around with the editor on my first project :slight_smile:

  1. I have a huge texture from a (100 meter) photogrammetry model. I tried different resolutions to load it. Now I use 8192 x 2 textures because with more I get problems. If I split it in 3 or 4 x 8192 textures, there is some issue and not all texture parts are loading, instead displayed black.
    Is there a way to get a higher resolution without problems? min. 4 x 8192 would be nice.

Here is the project with 4 x 8192 for showing the issue:

Here is the same project with 2 x 8192 working fine:

  1. I want to put about 80-100 lights in the tunnel as ceiling illumination. I read that the nice point lights are not recommended because of the performance cost. Now I tried with spotlights. But if I put about 20 lights all assets disappear.


Thanks and Greetings,

WOW that’s a huge huge set of textures… It also looks like a super detailed model. You are going to blow the VRAM on nearly everything with that.

So firstly - for lights, you are probably going to have to bake them, or it’ll all fall apart. You could possible try to divide the scene up and load/unload elements of it as you explore.

You could try lowering the texture resolutions and decimating the model to try to get it into something reasonable. Next I guess the only thing would be to divide it up either in PC or in your modelling package.

An “OK” decimator and a pretty good texture resampler are in my plugin:

But really here I think that it probably needs a strategy for mesh patches etc unless you are targeting something super high end (and by the looks of things, more powerful than your dev rig).

To split the texture in more, smaller pieces was a good hint and worked.
Thanks for the replies

1 Like

On the subject of many lights, every dynamic light you create will increase the complexity of the shaders that are generated by the engine. After creating a certain number of lights, the shaders will no longer compile and geometry will not render. Ideally, the engine would do something smarter like just enable the most important lights but stay within the limits to allow compilation, but that’s now how things work right now (maybe @Mr_F will fix this one day! :smiley: ) .

When you want to create many static lights in an environment, it’s often much smarter to use lightmaps. You either generate lightmaps in Max/Maya or some other 3D tool, and import them into the Editor.

Or you can use runtime generated lightmaps. Read all about that here. It produces lower quality shadows but it’s easy to use and quick to set up.

Also make sure you enable texture compression on each of your textures! That won’t reduce quality too much, but will save memory.

@will I use already runtime generated lightmaps. Just the moving spheres have dynamic light. If I have done it right :slight_smile:

@Mr_F I read about the nice feature. But i think it is not available for me with a free account.

1 Like