Gsplats in webxr-ar

Hey , anyone noodled around with gsplats in ar?

I have some sort of transparency issue where its ghosting the object uniformly. As if opacity or alpha , whichever it uses isnt getting interpolated correctly.


To caveat,

I ingested the ply into houdini and remaped both opacity and alpha values to something obscenely high such as 50 for each point.
It didnt seem to make any difference as to how it would draw in ar mode.

There’s this related ticket: GSplats stereoscopic rendering (viewport size issues) · Issue #6053 · playcanvas/engine · GitHub

and also this WebXR AR - Opacity Blending · Issue #6052 · playcanvas/engine · GitHub

Ok fair enough.

Just out of curiosity , do you know If I could potentially prune the opacity attribute from the .ply and have it ignored by the playcanvas engine, I toyed around with changing the values yesterday but it seemed to have no effect so I am trying to figure out if there is anything I could do as a hotfix on my end.

You can skip it from rendering by supplying your shader. See example here:

You can modify the shader as I did (setting alpha to 1.0)

I think we already might handle no opacity in ply file. But I cannot say that is much tested path.