Glb viewer fails to show texture/mesh properly

I was able to load the .glb appropriately into blender, and see that the texture was rendered OK by blender. This seems to indicate an issue with the .glb viewers I tried with this file:

gramps/gramps_animated_full_1.glb at main · coderextreme/gramps (

Here are the online viewers I’ve tried:

glTF Viewer (

PlayCanvas glTF Viewer

The texture/mesh didn’t work

I just tried this one online, and it works!

glTF Sample Viewer (

So it appears that there are serious issues with viewing the .glb in some tools, namely, the above mentioned, and these:

Castle Model Viewer




There are plenty of data files, some as generated by X3D-Edit, for you to see in the repository.

coderextreme/gramps: Demo of glTF/glb textures vs X3D textures, exported from Blender (

By all means, write your own Inlines!

My suggestion, based on many long hours working with different data files, UV files, related to Gramps, is that negative coordinates in the TextureCoordinate (point field–UV coordinates in textures) are being ignored. But don’t take my word for it, try to fix the texture/mesh (.glb) in your viewers so it looks like Khronos’ viewer!


Thanks, I’ve created an issue to investigate this: Some glb files are not rendered correctly · Issue #6396 · playcanvas/engine · GitHub

This is what the model looks like imported into blender 4.0.2:

You’re right the khronos viewer handles the UVs better, but pretty much everything else looks weirder.

Its wrong because its reading alpha from the base color texuture. The whole object is set to alpha blend which is likely not intended. How it looks when turn off reading alpha from diffuseMap