GLB import - red icon


I just tried to import a glb file exported from blender, and i have this icon in the editor


When i right click, and “Open in viewer”, everything is fine :

Where am i wrong ?


Hi @vogloblinsky,

Are you able to share the project or GLB with me so I can investigate? (You’re doing nothing wrong, the glb import step is failing).


Yes, how can i share you the file ? by mail ?

Sure, or you can add me to the project with glb. I can download from there.


Hi @vogloblinsky,

Thanks to your repro we managed to find the issue. The code change is being reviewed and will hopefully be released within the next week or so.


Cool ! Thanks for the quick look up ! :clap: :pray:

The fix is now on PROD.

1 Like

Hi, I have the same problem with my glb file importing,
could you check my project as well?

I invited you to the project.

Thank you

Thanks @KyungseokMIN, looking…

Looks like we’re still not sanitising texture filenames correctly.

We will update our tooling to sanitise filenames better, but till then you could get this working by renaming your textures to something very bland @KyungseokMIN :slight_smile:


Still facing the same problem. Had manually replaced all the spaces in GLB file with underscores and run it through GLTF 2.0 Validator to double-check all errors with texture filenames. Opens in viewer but does not upload and gives a red icon both with and without Draco compression. Uploads fine with FBX, but model appears to be void when importing it to the scene.