Glass material is not visible in Blippar-playcanvas

So i am working on a playcanvas project where i am using Blippar for image tracking and spawning a cube on top of it.
To that cube i have attached a glass material, in editor the cube is visible clearly

but in the build, cube is not visible . I can only see the sphere which is placed inside it

Is there anything i can do about it??

Difficult to tell without a reproducible project. Does it render correctly without using Blippar?

No, its not visible without blippar either.
i am getting this error
“Shader [Shader Id 4 standard] requires texture sampler [uSceneColorMap] which has not been set, while rendering [Pass:RenderAction 0-6 Cam: Camera | Camera | World | Box]”

You need to call this on your camera component and set it to true:

1 Like

ok let me check it out

There are options on the camera component that you can set instead of doing this through code:

Yes, i can see the cube now, both with and without blippar.
Thanks to both of you

can u tell me what happened exactly and how with those 2 value enabled every thing is working fine
or is there a place where i can read it from?

Thank you guys again

Some material properties require extra captures of what has been rendered before (glass that has refraction for example)

Color grab captures what has been rendered to the color buffer and depth is for the depth buffer. In your case, it looks like you only need color grab for your glass.

Some more details here: Release v1.23.3 · playcanvas/editor · GitHub

thanks ill go through it

also see here Depth Layer | Learn PlayCanvas