Getting major issue in loading models from remote json - model is loading but not the texture

I am loading models from remote json files on my server. They were working fine but suddenly I have started getting issues. The model is being loaded correctly and the shaders as well but there is no texture now. Let me show an example.

This link is correct and on debugging the editor of the same i.e., there is no texture. Earlier the same editor was debugging fine.
Same is happening in my project. The day before yesterday’s build is showing textures but today’s build is not. All of the code and remote JSONs are same. And, also not getting texture on debug mode as well.
Please help out as soon as possible!

@dave Has there been a recent engine update? These warnings didn’t come up before?

Using engine version 1.6.2 seems to be fine?

The scene uses loadFromUrl:, "model", function (err, asset) {
        var entity = new pc.Entity();
        entity.model.model = asset.resource;;

Don’t have exact idea about engine update. Can you please help me out for what should I do now to overcome from the above issue?

Can I change the engine version and switch back to the previous one? If yes, how?

I was pinging Dave from the PlayCanvas in my last post.

What PlayCanvas plan are you on @garima.bhasin?

On organisation plan.

While the PlayCanvas team look and hopefully fix the issue:

Use this page for instructions to launch your editor version with an older engine:

Version 1.6.2 was the last version that worked.

When it comes to building, I’m assuming that you export the builds to be hosted somewhere else? In the exported build, replace the playcanvas engine script with the older build.

The list of releases can be found here:

Yes, we changed the standard material loader last week. Looks like this has introduced a problem loading data from path-based JSON file materials.

This change was launched with engine 1.6.3. I suggest using the method @yaustar suggests above to run using engine 1.6.2 while we issue a fix.

1 Like

How can I change the engine version to 1.6.2? I have no idea regarding this.

You can’t do this within the editor itself. You can only change what engine you launch the app with via link I sent above.

After you build the project for self hosting, you can swap out the playcanvas-latest.min.js to the older playcanvas version.

I tried the above way you mentioned.
Here is the url of my project I used finally with 1.6.2 engine -
I am still not getting textures in the models.

The local_engine attribute only works the on the launcher from the editor. Not the PlayCanvas served builds.

As you were on the ORG plan, I assumed that you will export the builds to host on your own servers, is this correct?

I am not exporting the build. I am just using build’s URL at the other place.

Can’t I solve this issue in the server builds?

Not that I’m aware of, unfortunately. It be nice if the editor allowed you to change the version to target during the builds.

@dave Can you help me out changing the engine version in the server builds.

Any idea about how much time will it take to fix the issue?
Also, If I will export the project to my own server then which file will I need to replace for stable version?


Latest stable version in this link is 1.6.4 and my projects’s playcanvas-stable.min.js also has the same version. From where can I get the previous version?

@yaustar I am looking for playcanvas engine version 1.6.3 or any previous one for the above issue. Can you help with some link? I am getting 1.6.4 stable version everywhere but it’s same to the one I have in my project and getting texture issue.