[FIREFOX ISSUE] Embedded iFrame Not Responding to Input


I’ve implemented (read: stolen) the code from this project to render an iframe on a 3D plane.

It works like a charm in Safari and Edge, but not in Firefox.

In Firefox, the iframe won’t respond to any mouse input. It renders fine (so far in my testing), but scrolling or clicking any interactive pieces doesn’t do anything. It’s like the input gets gobbled by the canvas element? Again, it works in the other browsers I’ve tested…

I’ve tried to scour the internet for mozilla-specific issues with iframes and mouse events but come up empty. Any ideas why this might be happening?

Thank you in advance!

I found the SOURCE of the problem: something Firefox introduced called “fission” that separates webpages into their own separate processes. If you go to about:config and set ‘fission.autostart’ to ‘false’, the issue goes away but only for your browser where you have done this.

Apparently this shouldn’t be a problem if you don’t use the iframe to embed content from an external domain - which is fine for my use case (interactable virtual computer screens), because I’ll be hosting them on the same domain where I publish the game.

This has allowed me to continue developing in Firefox at least and hopefully helps out someone else. Dunno if I should mark this as ‘solved’ exactly though - I still have not tested with a published build and locally-sourced (organic freerange) iframes.