FBX import problem

I have some problems with uploading a FBX model from MAYA. The only message that shows
up is “[object XMLHttpRequestProgressEvent]”. I also tried to upload a model which worked
fine 2 weeks ago - getting the same error message now. There is enough space in our account
so this can’t be the problem. Any idea why the upload doesn’t work?

I don’t suppose you can share a DropBox link to the FBX file can you? Would be useful for us to test here.

Hi will,

thanks for your reply. Here is the link (https://www.dropbox.com/s/uf6lovjemelphkf/PC_21.rar?dl=0)
Please let me know when you have downloaded the file. Thanks!

Got it. Thanks, I’ll take a look.

Hi @donvito, we have reproduced the problem here. We are investigating. We’ll let you know when we find out what is going on.

In the meantime, here is some advice for you:

  • Don’t upload ASCII FBX files to PlayCanvas. They are far bigger than binary FBX files. Your ASCII FBX is 72MB. If you export in binary mode, it is 17MB.
  • There are over 1600 mesh objects in that FBX file. Most of the model can be welded to reduce the number of draw calls at runtime. I would expect an object like that to have somewhere between 10 and 50 draw calls at the very maximum. 1600 is huge.

Thanks for your help and your advice! You are right the whole structure of the model can be improved a lot (merging objects, etc.). I am wondering that the model upload works 2-3 weeks ago and now it doesn’t. Now I have tried several different FBX export settings (binary, ascii, etc.) merging the whole model,… but nothing works.

The upload problem is now fixed. Thanks for bringing this to our attention. :smile:

Thank you very much for the prompt fix - it works fine now!