FBX import error


I’m encountering some errors when uploading my fbx model file(with animation) to playcanvas. In the beginning I uploaded a 27mb fbx model with animation to playcanvas, but it wont get processed as an import error showed up with no further information on why it failed. After several attempt, i exported another smaller version of that fbx(8mb), now it can be processed and everything showed up in my assets panel. However when i add model into my scene i noticed that all the materials mapped to model were lost, but the materials were imported correctly into my assets panel.

I was wondering if someone else had this situation before? and what could possibly cause the import error when uploading fbx file.


Though we can support quite large FBX files. It looks like your file was too big for our importer. We’ve just upgraded the importing serving so it might be better now. I’ve imported your original 28MB asset with no problems.

As to your materials, I’ve just tried importing your file and the materials seem to be attached correctly. We did have a bug last week where materials were not imported correctly but that should no longer be the case. Can you go into any more details? Or is the problem now solved?

Hey Dave
I just tried it again, and it’s all godd now. Thanks!