Failed to initialize basis worker: CompileError: WebAssembly.Module doesn't parse at byte 0:

Hello, I am getting this error message when running my app on an iPad, I updated last night to the latest iOS 15.5 (iPAD)

failed to initialize basis worker: CompileError: WebAssembly.Module doesn’t parse at byte 0: module doesn’t start with ‘\0asm’

I am testing old and new projects, and in all of them they throw this error when executing the app from playcanvas

In android, I don’t see this error. I need help, urgently.

I’m just updating a device to 15.5 to have a look now

1 Like

I discovered that the error occurs when I pass the generated link from my desktop to the ipad, and run the project from a link. But if I open the editor on the ipad, and PLAY my project from the ipad itself, the error does not appear.

thanks for the support

I can’t reproduce it from this project via the following links:


Launch tab:
Publish link (iframe): Basis Example - PLAYCANVAS
Publish link (without iframe): Basis Example

Can you provide a link or project where it fails for you as well as the steps to reproduce the issue please?

yes, how is your user to add it to the project

029 - Insigne 03 | Editor (

I tried the example project that you just sent, and the error does not reproduce either, but in my project, it does.

Can you add ‘yaustar’ to the project please?


remember that it only plays, when you pass the playcanvas link of the running project, to an ipad or iphone

try that link on your ipad

029 - Insigne 03 | Launch (

I’ve tried on my iPhone (I don’t have access to an iPad) by typing the URL directly into the address bar and cannot reproduce the error unfortunately

I also tried launching from the editor tab and can’t reproduce the issue either

ok, thanks for your support, I have ways to test this, launching the editor on the same ipad, and the error does not appear, so I will use that way.

I will try with a lower end device to see if that helps repro’ing the issue

I would also try changing the asset retries to 5 to see if that helps?

I’ll try that, if you need to re-enter the project, let me know, for now I’ve withdrawn your access, as the project is highly confidential.