Exporting FBX from blender with correct origin

I’m having a hard time placing an imported FBX model because it’s origin isn’t at the model position. Is there anything I can do in Blender to fix that or maybe PlayCanvas?

1 Like

Yes! Reset the origin of your geometry, using one of these options:


For some reason that modifies the look of the geometry, is there a way to avoid that?

I think you need first to group your geometry, and reset the origin of that group. So the relative position of your objects stays the same.

@Leonidas is right. If you’re in object mode in blender, and can select multiple objects (let’s say a sphere and a cube) you’d need to select all of them and use join to make them into one object. This basically creates one single mesh, which you can still alter in ways using edit mode, but it will allow you to change the origin of all objects without messing up the geometry.

I set the 3d cursor on the object and then set the origin to the 3d cursor, but it is still off in playcanvas.

If you haven’t you have to re-export the geometry as an fbx and re-upload it to the project. If that’s not the issue, I’ve had the same problem and I’ve either had to place the new model manually into the entities model component or recreate the entity with the model on it from scratch. For the first option just find the model component, click the x above the asset name and drag the new model into the box.
(Sorry if I’m pointing out the obvious, but it doesn’t hurt to be specific)

I did reimport the fbx, but will try to do the manual entity thing. Thanks @Ryan

@Ryan I don’t think the second option works, it resizes the entity. I’ve tried reexporting but no luck.

Edit: looks like moving it to 0, 0, 0 in Blender helped.

So the thing that isn’t easy is setting the origin, what’s the easiest way to do that accurately?

Edit: I export the object to fbx, then in a new blender project import it back in and adjust it’s position in front view. Seems to work well.