Error loading glb

Hi, I have one model (out of hundreds) which errors when loading. It doesn’t seem to be any different to anything else and loads perfectly well both in the editor and in the viewer…but not in my app. I tried re-importing the obj file but still get the error when running the app. Any ideas?

Is the asset valid? ie. Does it have a filesize that makes sense/not 0?

I think I still have access to the project, which branch is this in and how do I reproduce it?

Yes, it all seems to be fine. If you just run the project from the init scene the error will happen. The asset (Beautyrest_PressureSmart_Plush_George) is in the following location:

Thanks, investigating now

At the moment, it’s requesting 2500 network requests and throwing a lot of the following errors

Looks like it’s a Chrome issue for these errors:

I can’t reproduce the 500 error with the GLB though.

I just updated chrome and don’t get the 500 anymore, but yes…I see 1000 ; Failed to load resource: net::ERR_INSUFFICIENT_RESOURCES errors…

…but my app still seems to work without any issues…

Should I care about the errors? My page really only has about 40 images or so loaded…not the 440+ described in the forum post.


Depends on how this app is going to be ran.

If it’s a webapp, it’s downloading 430MB on preload which is huge and ideally sections should be downloaded on demand.

It’s possible that an image or several may never get loaded so it does raise some concern from me.

It is a Chrome issue though so little we can do from the PlayCanvas side besides throttling the network requests