Does the clearcoat material not work for glTF files?

Using the khronos glTF Sample Viewer you can see how the clearcoat material should look like:

But wheb loading this into the Playcanvas viewer, I get this:

Does Playcanvas not support clearcoat?

Calling @mvaligursky @Gustav_Sterbrant, most likely they will have a point of view on this (it may take a while for them to answer due to holidays).

Hello everyone!

I opened the Clear Coat Test from the glTF repo and it looks like this in the model viewer:

It appears to me that clear coat is working, the base layer has only ambient, the coated has both specular and ambient, and the coat only has no diffuse color at all.


1 Like

@simmania Would it be possible to provide a link to what you’re seeing so we can investigate it further?

Hi @simmania,

We were running an old version of the engine when you tried. Please test again - model viewer is running on latest engine now.


I compared the Khronos viewer and PlayCanvas viewer again. See picture:

The difference between Base layer and Coated colums in the PLayCanvas viewer is minimal.
While in the Khronos viewer, the difference is huge.

Hi @simmania,

I think you’re comparing with different environment maps.

Try using the same environment map in both viewers to see any real differences.

I’ve tried a few side-by-side myself:

You can see the background is different (which is expected), but the lighting matches.


The other thing is our viewer supports an extra directional light. When comparing with other viewers, make sure the directional light is disabled (by setting “Direct” to 0.0).