(Corrupted?) Template issues

Hey hey

I applied some changes to a template, added some entities, removed some, applied these changes and now the template is in a state that can’t be fully applied. As you can see, it shows that an entity was removed, but I can’t apply this change, I can only revert it.

If revert this change, the removed entity gets recreated, but the change doesn’t disappear. It still tells me that I can only revert this change, but not apply it. And the entity that was recreated is treated as a new entity, that I can add to the template. Also, whenever I press “Revert” the message at the bottom left tells me “revert deleted entity d10a2645-b2dc-4650-8079-01c844141df5”. The GUID of the recreated entity will always be the same.

It currently doesn’t seem to break the scene, make our game unplayable, or break the editor, like was the case with corrupted templates in the past. But applying changes to template instances across multiple scenes is now broken, as I cannot be sure that entities are really removed.

Do you know what could be the cause for that? Can I fix this in some way?


Hi @AliMoe,

This sounds pretty serious. Are you able to share the repro with us?


1 Like

I’m not sure how to consistently recreate this issue, it just happend twice in a very short time frame. Now I’m a bit hesitant to make big changes in our templates.

I will ask if maybe we can share the project with you.

1 Like

Update: I was able to repair the templates. I tried applying the changes in various scenes and in one of them it worked, although I think I didn’t do anything differently than in the other scenes.

Something that came to mind that might have caused this issue - I often have 2 or 3 browser tabs with the editor in different scenes open at the same time, since we load more than one scene when we start our game. Could it be that that could be related to the templates gettting into a weird state, maybe by trying to synchronize them across multiple tabs?

1 Like

Not sure @AliMoe , perhaps. It’s great feedback that we’ll keep in mind. Thanks for the update!

Just in case you want to take a look, I created a branch from a previous checkpoint, where the templates where still in this weird state. If you want we could give you the project id and branch hash.