Cocoon js - different results

I’m loading this game in the Cocoon JS launcher on an iPad mini running IOS 7.
I’m seeing different results on the iPad compared to the web. The web is fine. In Cocoon js I just see a large black poly (looks like the camera is zoomed in really far).
I’ve tried this with a simple spinning cube demo too and get similar results.
In Cocoon I get no errors or warnings.

cocoon js:

Hello, I am Iker, CTO at Ludei (creators of CocoonJS).

I have been able to reproduce the error. The good news are that the latest version of the launcher we are working on (still not published/released) solves the problem (tested both on iOS 7 and 8).

My recommendation would be to give the cloud compiler a try. Compile your project on the cloud that we constantly update (the itunes store updates take more time as Apple has to review the app).

Also, give the Android launcher a try if you have the option to get an Android device.

Sorry for the inconveniences.


1 Like

Thanks. Yes I got it to build a launcher and it works on iOS 7 now.
Had to turn off dynamic shadows and the bloom effect to get my quite simple scene running at 60fps on an iPad Mini.