Cannot read .json as in "Loading JSON Data" example [SOLVED]

Hello - I cannot read .json-files as explained in the example below:

I use a link to my webpage that already has CORS permissions?

This is how my json-file looks like:
{ “current_user_url”: “”,
“current_user_authorizations_html_url”: “{/client_id}

Below " JSON Data from a remote URL"
it only says:

PS: currently testing with other online json-resources

ok, so now I published the project instead - and it works while referring to a json on the same (my) domain.

I am going to mark this as solved soon, but meanwhile; I think it could be very useful to get feedback on the issue of:
Howcome the playcanvas domain ( have a none-sandboxlike/CORS-like connection to the
(those are obviously not under same domain)

As such: The deveolper of the example should not write “JSON Data from a remote URL”, but maybe “JSON Data from a parallel domain-URL”? :slight_smile:

The console shows the error when you launch it:

You are loading http content from https source so the browser doesn’t allow that.

Either change it so you are using or launch using http (ie:

ok … nice point - I already tried it on my SSL certificate website - but I guess the trick is:

  1. works by http alone, when url to url within same domain
  2. works by https, when referenced between two completely different sites (both being https-sites)
  1. works by http to http when referenced between two completely different sites

See link posted above:

4. works from http to https