Cannot publish at the moment?

Hi, folks,

I cannot seem to publish my builds right now. I’ve tried it with three different projects, but all publishing failed.
This is the first project I wanna publish.

I even tried publishing a simple scene just with a box and camera, but still failed. The loading circle just kept going and going, like this.

Can someone plz help?
I have to publish it in 5 hours, can someone plz help? It’s kind of emergency…

Now the building somehow finished after a long running, but I don’t know if it successfully finished…
When I run the build, it gived me this in browser console,

Don’r really know what happened…


Can you please retry publishing your project now? We are looking into the issues at the moment. Let me know if it works for you.

hi vaios,

I can publish it now, but with errors. It might be caused by Json.
In my project, I didn’t use json files. Where I use json is in one of my script init function like this

 this.tableData_stationInAll =
            "项目": "终端总数",
            "值": 44, 
            "项目": "快充终端数",
            "值": 44, 
            "项目": "慢充终端数",
            "值": 0, 
            "项目": "快充预留数",
            "值": 0, 
            "项目": "总充电量",
            "值": 654123, 
            "项目": "总充电时长",
            "值": 5555, 
            "项目": "总充电次数",
            "值": 5417, 
            "项目": "当月利用率",
            "值": "54%", 

But when I played my publish, it told me there might be something wrong with json like the photo I posted.
I’m still trooble shooting.

It looks like some of your models were not published right… I’m looking into it…

You just remind me of that, the model is also actually a json file in playcanvas. I will look into it.

It is definitely not normal for a build to take so long to publish. Usually even large builds finish in about a few seconds. There is something in your project I think that causes an issue, still looking into it…

Yes, it is really wierd… and I guess I ve already got the bug. As you guess, it is caused by a bus model in the Bus Test folder in my project. I deleted all the models one by one, and that one is the last. Without that bus model, the build finally can run. But I’m not quite so sure if other models can still trigger this problem… I’ll try to all other models back, and see what will happen

And I just found it takes quite a long time to build a small project with a scene just contains a camera and a box. dont know why… Moreover, there is another problem about click event. It basically tells e is not defined,, this.onSelect, this);

   EntityPickChecker.prototype.onSelect = function (e) 

this problem nevers shows up in debugging, but occurs in build…
I guess there might be something wrong with the build …

Which project is that?

Can you try something for me please? When you publish untick the Concatenate Scripts option and then build. Let me know if that works for you.

Hi mate, I just tried it like five or six times as you said.

Sometimes it finishes building in seconds, sometimes it just stucks.

I’ve already asked my workmates for help about the testing, will see what they got

There is a script called echarts.common.min.js which seems to be causing the issues when concatenating… Looking into that, but If you build without concatenating scripts it should work.

Yes, two of my workmates tried it with your way, unclicking concatenating, now it flies!! The script echarts is a kind of utility class to build charts like line chart, rader chart… Don’t know why it causes this problem.

Anyway, Thanks really much for helping me, man . Friday night, Bottom up!

I’ll push a fix soon about that sorry for the all the trouble!

It’s Ok, hope your fix will be on asap

I’ve pushed a fix for the concatenation issue, let me know if you have any more issues.