Build Issue "/thumbs/180.jpg" isn't a valid image

I tried to make a build of a project, if I open the url after uploading to our own server the website keeps reloading time and time again in the console the following error message can be found in the console:

“Error while trying to use the following icon from the Manifest: (Download error or resource isn’t a valid image)”

I made a testcase with a blank new project, the build doesn’t constantly reload, however the error message is the same Sana Kliniken Düsseldorf - Baby Galerie

It’s for the thumbnail/favicon for page

Don’t know why it isn’t included in the build (@dave a bug in the build system?)

The paths are in the mainfest.json file if you want to change it/remove the error.

Hi thanks for your reply,
I removed the entire icons array from the manifest
but there seem to be more issues - in the build version I then get a lot of warnings reading
“playcanvas-stable.min.js:929 script registry already has ‘uiInteractions’ script, define ‘swap’ method for new script type to enable code hot swapping” and there-like - the playcanvas version is fine running without these warnings or any errors

Is there currently work in progress on the build chain?

@yaustar - if you enable “Concatenate Scripts” in the Launch options in the editor I get the same errors in the online version

I assume this is from your project?

As I don’t have the project to look at, my best guess is that you may have two scripts that use the same name of uiInteractions in pc.CreateScript('nameOfScriptHere')

I checked to make sure but no script has a the same name as another.

I found out that this happens automatically if the script doesn’t have a “swap” function
if I declare an empty swap function the warning disappears

That warning shouldn’t come up even if you don’t have that function. Could you share the project or a build of the project for me to check please?

@yaustar I just created a build and had the same error form the origin of this post again - “/thumbs/180.jpg” isn’t a valid image - was/is this a bug in the build system or something else?

It’s a bug in the build system. @will should take a quick look at it. It’s doesn’t break the app itself, it’s just missing the favicon.

*edit: should be able to take a quick a look at it :sweat_smile:

1 Like

Investigating… :face_with_monocle:


Looks like the manifest.json is possibly legacy from the days of Firefox OS. It’s not really required TBH. You can safely delete it for now. But I’ll add a bug to our tracker to get rid of it (providing we don’t discover a good reason to keep it).