[BUG?] Texture not displayed on Image Element in Editor

Hi everyone,

This is a behaviour that I observed and that may be a bug.

I started a blank project, and tried different ways to add an image element in the editor :

  • Right-click on Root -> New entity -> Right-click on new entity -> Add component -> Element. The created element is by default a Text element. I switch it to Image. Nothing appears. Applying a texture or changing the colour doesn’t change anything.

  • Tried the same, but by adding the component element from the entity panel on the righ-hand side of the screen. Same effect, image still not visible.

  • Right-click on Root -> New entity -> Image Element. This displays a white image. I can change its colour, or assign a texture. However, if I swith to Text element, and then back to Image, the image is gone again.

All tests were also done as a child of a 2D screen, with same results.

As mcmorry mentionned here, refreshing the page makes the image appear.

Thanks and have a nice day ! :grinning: