Audio not functioning when built to an APK through Cordova or GoNative

I have made a Flappy Bird fork to recreate the problem and it still happens (It seems to happen with all PlayCanvas programs).

Here is a list of audio mediums which I’ve confirmed DO work:

  • PC

  • Mac

  • IOS (Safari and Chrome on an iPad latest IOS

  • Android Emulators (Likely all of them. Tried on Android Studio emulator and other 3rd party services)

  • Samsung internet app (On a Samsung A32 5G running Android 12)

Here is a list of audio mediums which DO NOT work:

  • Chrome (On a Samsung A32 5G running Android 12)

  • Installation as a Cordova or GoNative application (On a Samsung A32 5G running Android 12)

I have tried to troubleshoot this issue myself through debugging and applying fixes for other peoples similar issues but none of these approaches have in any way furthered a solution into existence.

Here is the Flappy Bird fork in which the problem can be observed: Fork of - PLAYCANVAS

Odd. Your fork works on my Chrome on Google Pixel 2.

You are using OGG format which should work on Chrome according to "ogg" | Can I use... Support tables for HTML5, CSS3, etc

Does it work if you used the mp3 versions of audio?

Nope, it was originally mp3s but someone had some luck fixing their audio issue switching from mp3 to ogg so I tried it but no luck.

Unfortunately, I don’t know what it could be and it seems specific to that device and Chrome. Have you tried other Android devices?

I’ve just tried an identical Samsung Galaxy A32 5G and it seems that model of phone has issues. I’ve also tried it on a Samsung Galaxy A10e and it works as it should. I’m still not sure why it would work on an A10e and not an A32. It seems maybe it has something to do with Android 12 as the A10e is running on Android 11 while the A32s are running on Android 12. Although my emulation environment in Android Studio is that of an A32 running Android 12 (which works with sound and all) so I’m completely lost for a solution.

Do you see any errors or messages in Chrome Devtools when running on the A32?

I’m unsure how to open Chrome Devtools on mobile but I have made a development. I have a pair of Bluetooth headphones and I decided to connect them to see if it made a difference. When I connected them with the program already open the sound didn’t work but if I restarted the application with them connected then the audio would work. Then if I disconnected my headphones in the middle of the audio working the audio would continue working until I restarted the application at which time it would revert to its broken state.

Hello @Npet2301 ,

I’ve tested the link of the published app on my personal device which happens to be an A32 5G running Android 12, and audio works fine.

1 Like

Thanks for testing it out on a phone with identical specs. That’s minimized some variables. I’ll go check out my phone settings and post the results here in case someone in the future has the same issue.