Animations Suddenly Will Not Play in the Editor

Hi, Suddenly animation previews within the editor are no longer playable within the preview window: when clicking on the animation I’m getting the following error in the bottom left in red: “Invalid state error. Failed to construct ImageData. The input data length is not a multiple of 4.” These animations were working in preview mode a few hours ago. Did something change?

Hi @jasondalycan! I have seen this error a lot in my project, so it’s not a new error. I don’t know what is causing this. Can you please take a look @Elliott?

Is this reproducible for you? (Even after a browser restart?)

Do you know what steps you did before encountering this error for us to try to reproduce?

Yes this happens even after a browser relaunch. To reproduce:

  • Export an animation from Mixamo
  • Load it into PlayCanvas
  • Click on the animation (
  • The error appears at the bottom right
    I just tested again and same issue

Hmm, I can’t reproduce the issue here locally:

Can you share a project that has the issue just in case it’s project specific?

Yes sure here’s a public project where I’m having this issue: PlayCanvas 3D HTML5 Game Engine

See the error I’m getting:

I can’t reproduce here locally unfortunately :thinking:

Interesting, I just tried in Edge and the error isn’t showing either but when I go back to Chrome the error is showing up again. I’ll see if it’s something local to my browser and will let you know.

Do you have any Chrome extensions installed etc?

I do, but I just disabled all of them, restarted Chrome and the error persists.

@yaustar I just logged into another PC and tried via Chrome - I received the same error.

That’s really odd as Edge is Chromium based and I can’t reproduce the error here on either of my laptops with Chrome :thinking:

Can you open devtools and post the error and callstack please? That may help narrow down the issue

Yes sure attached is the stack trace in dev tools:

Also as an FYI, I tried Chrome on yet another PC and encountered the same issue again. Perhaps it’s related to my PlayCanvas account?

1 Like

Can you also try running this WebGL report please? WebGL Report and post screenshot of the report

Added a ticket to watch over this: Anim Preview exception, Failed to construct ImageData. The input data length is not a multiple of 4 · Issue #1005 · playcanvas/editor · GitHub

Yes sure see the following:

Hmm, I have the team look at what could be causing it. Difficult to do without reproducing it ourselves though