Ammo error on Xiaomi Note 8

hello guys I have this problem on Xiaomi note 8

I’ve imported again, cleared the cache, I don’t know where to look anymore.

Have you tried it on other devices as well?

on iphone 7 is also giving the same error

are the only devices I have to test

You can try if other projects gives the same error. Otherwise there is something wrong in your project. If you share a link to your project it’s easier to help.

I create a new blank project, and this one giving the same error :frowning:

I think I saw this the other day. I think I needed set the asset to preload

1 Like

I have looked at the project and I don’t see any differences with my own projects. But the project is also not giving an error on my iPhone 12 pro. So I’m not sure what has to set on preload @Kulodo133?

The ammo.wasm.js

Can you try that @vgupgrade?


On bluestack android emulator :frowning:

I’m afraid someone from the PlayCanvas Team will have to take a look at this.

Did it work on Xiaomi note 8 and iPhone 7?


I think it’s a browser caching issue on the mobile . With a blank test project I can create/fix the error by toggling preload but I need to kill the iOS safari browser and then then “clear history and website data” in safari setting settings each time to see the fix/error take effect

1 Like

When you load it on a phone/emulator, make sure you first login to the Editor, and launch the application from there. Do not launch the application by the direct link to the unpublished build, otherwise it will not pull the resources correctly. Another option, is to publish the app, and then open the published URL from the other device.

1 Like

Can you also try a known working project like this one please?

1 Like

Your project loads fine on my Android device.

So this leads to potential issues on your local network, devices or geographic location.

Have you tried loading these projects on your phone’s 4G network?


people do not know if it was some black magic, but today when testing it is working on all devices, in xiaomi only the message: Error loading scripts. Open the details of the browser console.

Good. It’s already an improvement