Alpha blending problems

Hello there, so I ran into a few problems. First one is alpha blending. Heres how it looks from 2 different angles:

Any solutions to overcome this?

Make sure you disable Depth Write on the alphablended material.

And material that don’t needs to be blended (such as grass), please disable any blending on it.

Strangely, that worked, I thought i’ve tried doing that alrdy, apparently not. :stuck_out_tongue: thanks