Additive layer blending, huge difference between FBX and GLB files


We have a character setup for our upcoming shooter, and up until now we have used FBX files.
But for specific reasons we want to switch to GLB files.

I export these from blender.

For our character we use the Anim State Graph and additively blend layers to, for example, look up/down.
This looks great with our FBX files, but completely wrong with the GLB files.

Example additive layer blending: FBX on the left, GLB on the right.


I have tried so many different export settings, and nothing seems to work. :sweat_smile:
Small note: The animation looks fine in the preview window.

These are my asset import settings:

Does anyone have a suggestion?


1 Like

Would you happen to have a repro project for the team to look at? If the asset is private, you can create a private project and add user “slimbuck” to it.

Ping @slimbuck

Yeah, it’s a private project. I’ll add @slimbuck to it.

Edit: I made a fresh project, with the 2 different assets.

Okay, I did some more testing and I found the ‘culprit’.

Under the GLTF export settings in blender, you can choose to export as the current frame.
If you disable this, you get the t-posed model. This is what I initially used, as this is the most common setup in our projects. Most of the time you do not want your active action as the default pose on your model.

With Use Current Frame disabled, regular animations will still show correctly.
However, the blending is incorrect, as shown in the gif below.


Conclusion: Enabling Use Current Frame no longer breaks blending.

I also noticed something else, shown on the left in the GIF.
When renaming the FBX template in the scene, animations stopped working.
This does not happen on the GLB Templates.