3ds Max Morpher to PC

Hello. When i am exporting an fbx with a morpher i cant seem to get the morph to play inside of PC. If i bring the fbx back into 3ds max I have the morph data. The animation of the box moving comes in but not the morph. I am not sure where the data is getting stripped out. I have turned off auto glb convert thinking that might be the issue but still get the same thing. Any ideas? I have included the fbx file.

Link is broken :frowning:

Try: https://catbox.moe/

The link worked for me.

So I imported your file (drag & drop) to Playcanvas Editor. It generated glb file.
I then downloaded the glb file, drag & dropped it to our viewer (PlayCanvas glTF Viewer) … and the morph was there - there’s a slider on the left bottom.

So that looks like it works to me?

I actually did the exact same thing. and got the same results as you.
I add an animation component to the 3d model and add the animation and the morph does not show.
are morph targets not run by animation?
can morphing be viewed in the editor?

well i was able to do it with something like

this.CubeMorph.model.meshInstances[0].morphInstance.setWeight(0, this.count);

Is there a cleaner way instead of guessing the morph is at spot 0?
and is there a way to view and preview these inside the editor

Morph targets can be driven by animations as well, that usually works without a problem.

As you discovered, you can also run them from script. To get names of the targets, you can search this array:



is there a reason why my animation is now showing it?
it imports an animation with the fbx

you say you added ‘animation’ component. I’m not sure that one supports morphs, I don 't think it does.

My recommendation would be to use new ‘anim’ component, that one does.

1 Like

Side note: You can use https://developer.playcanvas.com/en/api/pc.AnimComponentLayer.html#transition to ‘play’ animations/states much in the same way as the old Animation Component’s transition function without having to setup parameters and transitions in the state graph.