VR stuff seems pretty broken?

I’ve been playtin around with the VR stuff:

-just making a VR preset project, publishing it: doesn’t work on mobile. clicking the screen does nothing, device orientation does nothing.

-adjusting script order via this tutorial: http://developer.playcanvas.com/en/tutorials/beginner/cardboard-vr/ doesn’t work on mobile. I don’t even see anything. I presume clicking the screen does nothing, device orientation does nothing, because nothing happens when I tap and/or change orientation.

-running the mentioned project PlayCanvas 3D HTML5 Game Engine - doesn’t work on mobile, see above

-accidentally stumbling over the ‘old’? project PlayCanvas 3D HTML5 Game Engine - works on mobile, but still shows safari menu bar, which makes it unuseable for cardboard

-searching the forum for ‘VR’ doesn’t work, because seach string need to be >3 characters

so, yeah…

I updated the scripts to the latest version from GitHub as per this suggestion VR Starter Kit causing eyestrain

same thing on iOS, I just see a blurred screen, tapping and/or moving does nothing.

I also tried this link http://playcanv.as/b/nH6jQZSb
same behaviour on iOS (blurred screen, nothing else)

If you are using iOS it prevents orientation events working on our published builds at the moment (we’re working on a fix). If you use the “embed” link. Insert an /e/in the URL. E.g. http://playcanv.as/e/b/nH6jQZSb1 then the redirect works.

I’ve tried the links and they seem to work OK on android.

1 Like

device orientation works with that link, tapping doesn’t do anything still. (iOS)

I’ve reproduced this on iOS. We’ll fix in the morning. :slight_smile: Thanks for bringing this to our attention.

1 Like