Unable to run after fork of projects

sometimes after forking a projects, when i run it, it get error !
forexample this project, PlayCanvas 3D HTML5 Game Engine
it’s work fine but when i fork it, it’s not working correctly and i get error when i run the project


You will have to find out where the error is coming from.

For example: it may be the developer is using asset.get(id) in his code. When forking a project the asset IDs change, so that will break that part.

is there any engine version option in editor ?

Yes, there is, you can find it in the project settings → editor.

There you will find only recent engine versions, but if you launch you will find a url param added in the address bar:


You can change that to any older version and press enter, the page will reload and the app will use that engine version.

1 Like

I understood something,
if I click play, it will be played correctly but I if i click on edit and then encounter to the editor if i click on launch it show me error !
even if i had not fork it

this error will be shown :
Cannot read properties of undefined (reading ‘meshInstances’)
which comes from this code :
var meshInstances = this.entity.model.meshInstances;

i presume that it related to engine version.

If you click Play, then the project uses the latest build the developer did. That will not break, since it’s not affected by any project changes.

That error most likely is coming from a missing model/asset, it may be similar to what I suggested above. You need to debug.

1 Like