Spine demo forked not working in iPad air first generation

Hi all,

I tested the following spines examples


in my iPad Air first generation, w/ IOS 12.5.6, and it is working normally, but when I fork both projects, they don’t work in my iPad Air anymore! I evaluated all settings in original and forked projects, but don’t find nothing different, someone knows why this happens?

P.S. Just to complement that the original and forked one are working normally in my work machine, a Win11 w/ Edge browser device.

Hi @Nelson_Alves and welcome,

Are you able to connect your iPad to a Mac and check the console for any errors?

Hi Leonidas,

I tested again the forked version of the first link and the snapshot is below.

But I tried to run the original version of the first link too and it stopped to work in my iPad Air and the snapshot below show the errors in console.

Ah right thanks! half_float textures not support most likely. @mvaligursky any idea how to fix this?

We test for half_float format but don’t use it if that is not supported. But there is no way to hide the generated error. This is non-issue, the problem must be elsewhere, but I’m not sure where.

could you also try running this?

1 Like

I tried to open the link in my iPad Air, but it throws an error in console.

could you expend that little triangle on the error to see more lines please.


@Leonidas and @mvaligursky

Thanks for the attention, but I think I will not evolve this. In fact, this iPad air is limited to IOS 12.5.6 and I will limit the requirements in my project to above this.


1 Like

This seems to be some unsupported javascript feature being used in that index.js file, some ES6 or similar, so that is different issue than before. I think engine examples need newer browser to run.


Did a bit more digging and it looks like it broke in engine release 1.55.0 so maybe it’s related to some shaders or material used in the Spine integration?

1 Like