[SOLVED] When duplicating a scene, entity attribute arrays contents are not duplicated


#1

Sample - I have a scene called ‘Evergreen’, with an entity that has a script, whose attributes look something like this:

BuildSpawnManager.attributes.add('prefabs_bigcitygreens', {type: 'entity', array: true, title: 'Character Prefabs (bigcitygreens)'});
BuildSpawnManager.attributes.add('prefabs_descendants', {type: 'entity', array: true, title: 'Character Prefabs (descendants)'});
BuildSpawnManager.attributes.add('prefabs_justrollwithit', {type: 'entity', array: true, title: 'Character Prefabs (jrwi)'});
BuildSpawnManager.attributes.add('prefabs_vampirina', {type: 'entity', array: true, title: 'Character Prefabs (vampirina)'});
BuildSpawnManager.attributes.add('prefabs_mmua', {type: 'entity', array: true, title: 'Character Prefabs (mmua)'});
BuildSpawnManager.attributes.add('prefabs_gabby', {type: 'entity', array: true, title: 'Character Prefabs (gabby)'});

Now I want to duplicate this scene. Everything works fine, no issues - however the contents of the above arrays are now empty, and look like this -

Copying array contents over worked fine on asset array types -
image

This is a pretty big issue sadly, because our scenes are quite complex with lots of entity arrays scattered about, that we now have to rebuild manually…


#2

I have reproduced this problem. I have logged it into our issue tracker. I’ll aim to get this investigated on Monday. Thanks so much for bringing this to our attention!


#3

A fix for this has now been deployed. Thank you for your patience. :pray: