[SOLVED] VR Not Working "This page isn't responding"

I am having trouble getting any Playcanvas VR content to work on my headset. When I try to switch to VR the app loads in my headset but then I am presented with a “This page is not responding message”, I can hear audio though. It seems isolated to Playcanvas as other WebXR content works fine. I have tried the default VR template and I have created a fork of the XR lab and both exhibit the same behaviour (NOTE: For the XR lab I had to disable the MOUSEDOWN event that was grabbing first person mouse control as it was preventing the VR button from working).

I am using a quest 2 through Oculus Link and I have tried using both Oculus and Steam VR as my OpenXR runtime. I have also tried both Edge and Chrome and both have the same issue. Interestingly if I use the Meta XR extension to simulate a headset in Chrome it works as intended also the demos work fine when running directly on the Quest 2 browser.

Here is a link to my fork of the XR Lab

Any help would be greatly appreciated.


It could be related to this: WebGL context must be marked as XR compatible

1 Like

Thanks for responding so quick. This was the fix I needed. If you can, it would be worth updating the VR templates to resolve this issue and the issue with the VR button being interrupted by the event which gives control to the mouse. It makes it just seem like Playcanvas VR doesn’t work in the current state. I’ve been really enjoying using playcanvas and have been recommending it to many other people, so thanks for helping me with this.

1 Like

We’ve released the XR fix to the Editor earlier today, so that should be all good I hope.