[SOLVED] Switching Scenes not Working

I’m working on this game, though I’m having a few issues with the scenes switching from the main menu to the first level. Though it’s strange, because I am using the same script for the Credits scene (with the tweak of the name of the scene, of course), and it worked for it.

Here is the script:
Screenshot 2023-05-10 6.25.57 PM
If you want to access the game, I’ll reply with that as well if you need it to figure out the issue.

@NerdyLoaf At first glance I see possible curly brace misplacement. What I mean is that each if() is not wrapped to contain one action. So directly after the Credits scene change should be one matching curly brace. Also the same after level 1. So Line 13 should have one matching brace and line 17’s brace should remain. I think it is also better if you would share a link to your game that way others can also have a look. Hope this helps.


@Tirk182 - Oh, okay! I think I see the issue there- Hopefully, I did this right.

Screenshot 2023-05-11 11.47.34 AM

It still isn’t working for me though. Here is the link to the game.

Hi @NerdyLoaf!

Have you added the script to an entity in your scene?

Can you share the editor link of your project please?

@Albertos , Yes, I have- It’s connected to the first text entity under the 2D screen.

And of course! Here’s the link.

There seems to be a problem with your script(s).

You probably renamed the script(s)?


If you parse the script on the entity, you can see that in the editor too.


I suggest to remove the script from the entity and add it again.

1 Like

Okay, so I noticed that the name in the script wasn’t lowercased how it was in the entity, so I changed that as well as removed the script from the entity and put it back on like you suggested, and thankfully it worked :sweat_smile: Thanks for the tips, @Albertos and @Tirk182

1 Like