[SOLVED] Shadow clipping rendering issue

Hi,

I have an issue with rendering of shadows in my project. (https://playcanvas.com/editor/project/736977)

Here is a video of the issue :

Where did i need to update settings ?

Thanks

Hi @vogloblinsky,

Find your active light, the one casting shadows and in the light component increase the shadows distance.

image

There are also cascaded shadows now supported by the engine which allow you to render longer shadows without sacrificing much the detail of closer shadows. You can enable that option in code right now, check this example:

https://playcanvas.github.io/#/graphics/shadow-cascades

1 Like

I’ve just exposed the cascades shadows to Editor now … it should come live sometimes next week when it gets released.

3 Likes

Thanks, i miss to watch light component. :sweat_smile:

1 Like

Shadow cascades work wonderfully! Thank you and the team for another excellent feature! :slightly_smiling_face:

3 Likes