[SOLVED] Self-hosted build won't load; "Failed to load resource"

Hello! I’ve uploaded a build to my website, but it won’t load on desktop or mobile – I just get the same green background, and a bunch of errors in the console. I’ve tried it on both Chrome and Firefox. I’ve attached an image of my errors. Is there something simple I’m missing?


Here’s the link to the build: Corporate

I’m coming from Unity and don’t have a lot of experience with web development, so any help is extremely appreciated. Thanks!

It looks like none of the JS files were uploaded or they are being blocked for some reason. Are the files in the right place?

Wait, I remember. GitHub pages has a weird restriction of file names with underscores. I think it ignores files with starting underscores by default. Try this: https://github.com/mpetrovich/stylemark/issues/65

Or rename the files to not have starting underscores and update the index.html.

See Can't get a build to work on GitHub Pages and [SOLVED] Can't get self hosting to work

Excellent, I added an empty file with the extension “.nojekyll” to the root of my pages repo and it fixed it. Thanks so much!

1 Like