[SOLVED] Problem with publish build

Have problems with publishing project (check the sceen)
Errors appeared after managing old branches (deleting some stuff)
How to solve the problem?
I also tried to export main project, and then reimport and problem was gone (but i want to solve it on current project because of branch history and e.t.c

Do you have any errors in the Editor in the browser devtools?

Have you tried publising again on that project?

I don’t have any problems in editor, i can run build in editor and everything is ok
But when i want to publish it, loading scenes is infinitive
and when i click on publish button loading also appears and i have 400 request (because scene wasn’t load)

My guess us there may be an issue with one of the scenes.

I will have to have a closer look tomorrow. Can you add ‘yaustar’ to the project please?

you mean to add to the team of the project?



I can reproduce the issue with that project. I will need to get another engineer to look at this

Forking the project does workaround the issue.

Can you continue work in a fork/you newly imported project while we look into this please?

yeah, i continue with new project
but I think that it is worth solving the problem so that it does not arise for someone in the future

Yes, I’ve created a ticket internally with the information here. It’s just something I can’t directly fix or help so need to escalate to someone else while ensuring that you aren’t blocked by this :slight_smile:

I managed to track down a possible root cause for this issue, related to deleted branches. I’m already working on a fix and it will be out by next Editor release.

Meanwhile, can you confirm if one of the project branches that could have been used to create a new Published Build was deleted recently? If so, I believe your issue will be resolved by next Editor release.

1 Like

yeah, it was.


Update: we’ve just released a new Editor version (Release v1.21.46 · playcanvas/editor · GitHub) which contains a fix for this issue. Thanks for reporting, @wazti !