[SOLVED] Primary build takes ages to just disable and enable entities

LAUNCH - PlayCanvas | HTML5 Game Engine

Hey everyone,

I have just published a game that works perfectly in the launch tab. However, when I run the primary build, the game takes a very long time to just enable and disable a couple of entities. Steps to repro the issue - click start, then press E. In the launch tab, after the screen goes white, it switches entities and swaps to a different view, but in the primary build, it just stays on the white screen.

Why does this happen? This is very urgent for my team and I since we have to submit this tomorrow.

Hello @DevilZ! Both versions work the same for me. The problem that keeps the screen white in both the launch and the build version is probably the error below:


Hmmm, I didn’t get this. Thanks for clarifying @Albertos, I’ll take a quick look.

Yes, I just saw this, I think it may have happened while publishing. There was a localStorage change in the code, but was not made by me, so it must have been accidental. Am testing the primary build now.

EDIT - Just confirming, I have been able to fix this now.

1 Like