[SOLVED] Possible outdated code

Hi! I hope you are having a great day/night/morning/evening! I have this code I am using for my project, from an first person movement tutorial. Whenever I check the console, after the game doesn’t work, it says “forward” is not defined. Here is the link! https://playcanvas.com/editor/code/810202?tabs=51327208 I hope you can help me, I am not sure if the term forward is outdated but this is the code from the tutorial, https://playcanvas.com/editor/code/405842?tabs=4468263, and it seems to work. @staff please help! Thanks!

Hi @CRAYPHiSHQUESTIONS! I’ve looked at the associated project, but I’m not getting the error you describe here. I see that you have changed the name of the script in question. You need to apply this change everywhere and parse the script. I also don’t see the camera attribute on your script component, but this is probably also solved after it.


(There are large files in your project, for example the 20mb skateboard. It’s better to make these files smaller for better stability and loading time).


Oh! I changed the name and everything works! I can’t believe it was such a silly mistake! Thank you!

1 Like