[SOLVED] Model scale troubles when changing animation

Hello, i have made a new project to put in evidence a model trouble when appling an animation, you can test it running the walk animation maybe some of you can find what’s wrong. Thanks

How do we reproduce the issue?

You play the walk animation in the entity

Found nothing? :frowning:

Sorry, been crazy busy. I have a look at it today

Hi @ayrin,

I think your walk animation is meant to be played with the icegar model only. If you do that the scale then is correct.

Same way if you add the human idle animation to the icegar model you will get a faulty scale.

1 Like

But since the bones name are the same why is it rescaled since before it wasn’t?

The animations include translations for the bones, so most likely those are scaled differently.

Where did you get these animations? Maybe you can scale them uniformly before exporting.

I got the walk animation from mixamo…i think…i don’t know much of blender so i don’t know how to scale the animation unluckly…but i don’t get why with old scripts i didn’t had this problem (same as the deer head you remember?)

Yes, I remember that. The issue most likely isn’t the old scripts but something in your project setup or a newer change in the engine.

You could try and work your way around it by scaling the model up/down, but the best thing would be to try and re-export the animations from mixamo.

awww would love that, when my 3ds max was working i had no problem, but till it stopped working, i had to move to blender, and i still have to understand how that works, and no much time to do that unluckly

1 Like

Solved the scale issue, but it say keycode is undefined … guess some wrong option in blender export? do you have any clue?

Hi @ayrin,

It sounds like an export issue, have you tried re-importing both your character model and animations?

If that continues to happen try posting a simple sample scene to take a look.

It’s a known problem with blender exportation fbx but i still have to find out what option i need to disable or enable…sigh

1 Like

It was not my model trouble, all fixed! YAY!

1 Like