[SOLVED] Mobile breaks after menu?

I’m pretty much done with the Mellow Tiger environment, but for one thing: The mobile controls work until the user returns to the menu for any reason. Then, if they return to exploring, the ‘look’ control stops functioning. Eventually I have found that both controls stop working.


Anyone have any ideas?

How do you go from/to the menu?

There are two mechanisms: one is a button in the menu (“Explore the Dreamscape”, choose the “Bare Bones” option for mobile). This corresponds to a “Menu” button which then appears, bottom center-screen, while exploring in first person.

For PC users, since mouse is captured, the ENTER key switches back and forth from the menu to exploration.

This works at first, until one taps the MENU button to return to the menu options. If they return to exploring, the right “look” invisible joystick seems inoperable or nonexistent. I’m thinking it gets moved or turned off somehow?

I can’t see the issue myself:

Well that’s frustrating. I guess I’m glad it isn’t an issue everyone might have. I’ll see what I can do to duplicate and document the issue.

You can’t see the finger presses, but when I come back from the menu the second time, you’ll see there is no “look” movement, only forward/back/side to side.

UPDATE: I added the visual elements to the joysticks so I could watch what happens. The problem seems to be when one clicks MENU the joystick (usually the right one) jumps to the MENU button location and sticks there. Not sure why-- it looks like I will need to make a way for the joystick locations to reset upon returning to exploration mode.

EDIT: Tried resetting position of joystick elements, and turning on/off the 2D screen elements (containing the joysticks), but no avail. Touching the Menu button (or the “explore” button from the menu), seems to grab and lock one or both of the joysticks. Any ideas?

FIXED. I had the script to be disabled upon Menu click, which caused the problem.

1 Like