[SOLVED] Loading Hanging on getContext

@bolton I reached out to Google for assistance since this seems Chrome-related rather than PlayCanvas-related. Here are their instructions:

Please have them file a bug on crbug.com, include the contents of Chrome’s about:gpu page using “Copy report to clipboard” and pasting the result, and tell me the bug ID once filed.

Bonus points if they can:

  1. Start from a clean browser session
  2. Open two windows
  3. Navigate one window to about:tracing, start a “Javascript & Rendering” trace
  4. Navigate the other window to the problematic page
  5. Reproduce the problem
  6. Stop the trace, save it, go into their Downloads folder and upload it to the bug report they filed.

If you can do that ASAP and let me know the bug ID, I’ll get them to investigate.

1 Like

Appreciated. Bug is filed (id 1202090). Attached the trace and a screenshot to the report (used your animation blend example rather than my project when reproducing). Just let me know if there’s anything else I can do.

Thanks again, this is really above and beyond support.


I’ve let my contact at Google know about the logged bug. Let’s wait for them to investigate and I’ll update you when I hear back. :smile:


@bolton I’ve had a read of the bug report on bugs.chromium.org and created a build of the PlayCanvas engine without the XR manager being created. Would you be able to try this build out please?



Hi @yaustar that looks like it fixes it. No initial hang and everything loads up in about 5 seconds. I’m hesitant to jinx it but seems like at least the mystery of the root cause is solved.

Is it safe to assume that the build would be self hosted rather than being on our servers? If so, the builds below can be used as long as XR is not needed and can be swapped with the engine version that the published build uses.

This builds are not well tested but the changes are pretty minor.


Yes, safe assumption. I’ll keep that build on hand in case this comes up again but for now I think I’ll stick with the standard unless it gets brought up from the client (seems super unlikely given the nature of the bug).

Thanks again!

1 Like


To wrap this up, looks like they’ve found the issue on Windows:


Looks like a fix is now deployed to the beta of SteamVR: