[SOLVED] Legacy Model format?

It seems as though the editor was updated today to convert newly imported models to GLB. That was quite a drastic and unexpected change for my team, as we are in the middle of a project that is very much tied to the old model format.

We attempted to use the new model import setting to “force legacy model v2” without any success. Are we to expect that setting to import the model in the traditional JSON format? Is it not currently working?

I’m excited by the prospect of the new format, but this forced change late in development will not be easy to overcome. Any input on the update would be most appreciated

Hi @explorebrian,

Invoking @will and @vaios to provide their insight on this!

1 Like

@explorebrian Apologies this is affecting you. What’s the project ID where you are seeing GLB files generated?

@will Looks to be affecting any project in our organization.

I also just created a public test project(678688) on my individual account and I’m getting glb files for both the model and the animation file, whether the “force legacy” checkbox is on or not.

Seemingly no issues with the model/animation. The format change is just unexpected

We’re disabling it for you. Hold on - it won’t take long.

1 Like

OK, we’ve disabled it. But if you have any projects where ‘Convert to GLB’ is enabled in the Settings -> Asset Tasks, just disable the checkbox.

Can you let me know if you’re good now?

@will I was able to disable the “Convert to GLB” option in that test project I sent you, and it looks like new imports come in as json. However, I’m not getting the option in the projects associated with my organization account. Is this a per-user or per-project change? We’d need it disabled for all our org users or at least our currently in-development projects.

Thanks for your assistance

This setting is per user / per project. It was only on for newly added users it shouldn’t affect any older projects or users who were already part of the project.

It shouldn’t have affected many projects as this was deployed a few hours ago.

And you are only going to see the checkbox if it is turned on for you so if you don’t see it then that means it’s off.

@vaios I’ve had 3 different users on three different existing projects in our organization that started getting glb files on fbx import this afternoon. Is that the current expected outcome as of the update a few hours ago? If so, is there any way to keep the legacy import format for those existing projects?

The deployment that happened a few hours ago would have affected any settings that were created for users when they logged into projects for the first time or when for some reason these settings did not exist for those users before.

The users that had the setting turned on for them should now be able to disable it from their Asset Tasks -> Settings. If this keeps happening for your projects even after disabling the flag please let us know.

@vaios I continue to get glb files on new fbx imports in any of my organization’s projects, and none show the “Convert to GLB” import setting option

We are going to look into this right away. Can you please DM me your organization and one of the affected project ids? Also if you can DM me your username it’d be great.


OK so it looks like there is another bug when it comes to projects owned by organizations that uses glb by default. We are disabling that as well until we fix it properly. I’ll update this thread once it’s done.

Really sorry for the inconvenience!

OK glb should be disabled for everyone now please let us know if something is not working and again sorry for the inconvenience!

1 Like

Thank you!
I came to this forum to specifically resolve this issue with .glb files.
Everything in our current project 578613 is all tied to .json files and any change to the file format. Please do not auto-switch our account to .glb files.
Btw- our account is a paid account since 2018. This didn’t just affect “new users” it affected us as well.
When i tried to import a new 3d model i was preparing for the game, it converted it to a .glb file, whereas i was expecting to see a .json file and our code is dependent on the .json files throughout the project.

Hi @polygrafix yes there was a bug related to organization accounts which should be fixed now. Sorry for the inconvenience!