[SOLVED] Intermittent error? ERR_HTTP2_PROTOCOL_ERROR 200

I’ve only started noticing this today, while testing out my game from the PlayCanvas editor, I’ll frequently get this error loading a particular asset on refresh:

GET https://launch.playcanvas.com/api/assets/files/Sound/BGM/bgm3_mix1.ogg?id=52236558&branchId=d35e7c6f-3e75-4ccd-b601-63772f2aad14&t=7f8e27a73ae4d1bb9d142cce8278f07b net::ERR_HTTP2_PROTOCOL_ERROR 200

Refreshing will often make the error go away, but it comes up pretty frequently, mostly with this particular file, but sometimes with other assets too. It’s preceded by GET: /api/assets/files/Sound/BGM/bgm3_mix1.ogg?id=52236558&branchId=d35e7c6f-3e75-4ccd-b601-63772f2aad14&t=7f8e27a73ae4d1bb9d142cce8278f07b - Error 0. Retrying in 200 ms.

It seems to happen less frequently now (it was on every page refresh a few hours ago. Now it’s on 2-3 out of every 10 refreshes).

Is anyone else experiencing this/is this something my project may be doing incorrectly?

I’ve had this once yesterday too, I didn’t think much of it at the time since it went away with a single refresh… After looking up the error message, it seems to be server related? See php - What's the net::ERR_HTTP2_PROTOCOL_ERROR about? - Stack Overflow. Calling @yaustar, could this be an issue related to the PlayCanvas server config?

This isn’t uncommon as network errors can cause a request to fail. It shouldn’t stop the asset from loading though.

It’s a bit worrying that it happens as often as “Now it’s on 2-3 out of every 10 refreshes).”

Can you report again the next time this happens and also a rough timestamp so we can try to investigate in logs please?

If it’s not preventing the asset from being used then that’s great! (haven’t gotten to the using audio part of this project yet but will be able to confirm soon.

Here are a few examples of it happening today plus timestamp:

GET: /api/assets/files/Sound/BGM/bgm3_mix1.ogg?id=52236558&branchId=d35e7c6f-3e75-4ccd-b601-63772f2aad14&t=7f8e27a73ae4d1bb9d142cce8278f07b - Error 0. Retrying in 200 ms
playcanvas-stable.dbg.js:2051 GET https://launch.playcanvas.com/api/assets/files/Sound/BGM/bgm3_mix1.ogg?id=52236558&branchId=d35e7c6f-3e75-4ccd-b601-63772f2aad14&t=7f8e27a73ae4d1bb9d142cce8278f07b net::ERR_HTTP2_PROTOCOL_ERROR 200
Fri Jul 23 2021 15:14:47 GMT-0400 (Eastern Daylight Time)

Another after a couple refreshes:

GET: /api/assets/files/Sound/BGM/bgm2.ogg?id=52188362&branchId=d35e7c6f-3e75-4ccd-b601-63772f2aad14&t=ad894b433ea3d1359aef1dff383db61e - Error 0. Retrying in 200 ms
playcanvas-stable.dbg.js:2051 GET https://launch.playcanvas.com/api/assets/files/Sound/BGM/bgm2.ogg?id=52188362&branchId=d35e7c6f-3e75-4ccd-b601-63772f2aad14&t=ad894b433ea3d1359aef1dff383db61e net::ERR_HTTP2_PROTOCOL_ERROR 200
Fri Jul 23 2021 15:30:25 GMT-0400 (Eastern Daylight Time)
1 Like

Can confirm the sound works fine when this error happens! So I’m not too worried about it for my project.


I spoke to the backend team and they think the error is on the server and that sometimes the reported size mismatches the actual size.

They are considering options but nothing in the short term.


We’re also getting this intermittently - maybe 50% of the time? Specifically for mp3 files.

Our implementation might be wrong but it looks as though the load operation does indeed error out, ceasing execution. I might have to put our asset loading in a try catch just for the mp3s :thinking:

Edit: Just confirmed that we’re still getting the error, albeit less frequently, even after we move to our own hosting.

@vaios Any ideas on this one?

@ChiefBreakeverything What browser are you using? We also had similar problems, which only occured in chromium browsers. Firefox worked without hickups.

1 Like

@LucaHeft I’m seeing it in Chrome but also on the Oculus Quest 2 browser, which is our primary platform :frowning: I’ll see if Firefox plays ball…

Is this only happening on the playcanvas.com or playcanv.as domains? Does it still happen when you self host?

Is it stopping the app from running correctly?

1 Like

Yes, it’s stopping the app from running. It happens with different files as well, but they’re always mp3.

Paging @sumygin about as he is investigating this issue

1 Like

A fix by @sumygin has been released. Can @ChiefBreakeverything and @OmarShehata please check your projects again please?

1 Like

@yaustar I can confirm it is still happening as of today. It’s particularly frequent on the Oculus Quest browser if that helps establish a cause, but it happens on Chrome as well.

@ChiefBreakeverything would it be possible to have access to the project that is cause this please? Add ‘yaustar’ if you can.

CC @yak32

1 Like

It’s a private project for a client - let me discuss with my team tomorrow to clear up any potential issues there first and then I’ll go ahead and add you! :slight_smile:

as I understand, it’s happening with your own backend as well, right? I fixed the issue with with our backend setup, so it’s a different cause here.

1 Like

@ChiefBreakeverything If it’s happening on your own hosting (sorry, I missed that you were self hosting), then it’s possible it’s related to the hosting provider and/or the browser.

Is it happening when running from our services?

1 Like

It happens most frequently when using launch.playcanvas links, i.e. when testing during development.

I made a PlayCanvas-hosted build recently (https://playcanv.as/b/…) and it seems to still happen albeit much less frequently.

I’m also told that it appears in our Sentry diagnostics when deployed on our own hosting, although I don’t know to what frequency. It seems less frequent to me but its anecdotal.

I’ve sent you a DM for follow-up :slight_smile: thanks so much for the assistance here.