[SOLVED] Importing FBX does not generate materials and a GLB model in PlayCanvas

Hello, I’m using my general workflow but when I import my fbx files, there is only the fbx source and it does not produce the usual materials, textures, and glb model…

Any idea why is this?

Using blender, using native exporter, I select my object, embed textures, selected mesh only, select mesh.

It usually works, but it doesn’t work this time. After upload there is only the fbx source

Shit it happens to me too… and it freaks me out…


Hmm I’m having trouble reproducing the issue locally using Kenney’s assets

Is this with all assets or just these particular ones? Would you be able to share the assets?

Here’s the asset link https://drive.google.com/file/d/1o35Mmq9Pb9EFOd5lNHVljSCD2LtrZZ9v/view?usp=sharing

I tried to upload other that is previously successfully uploaded and had no problem uploading…

I’m using the same workflow and carefully re-exported the asset but it’s still does not generate the glb, materials, and textures

I have no idea… I did this many times before and had no problem!


These are my settings from blender

@slimbuck or @vaios Can you take a look at this when you have time please? It seems like most of the textures are embedded in the FBX but after it is process, none of the assets appear.

Any idea? It seems that I have did the right thing and assets are supposed to be generated am I correct?

I don’t know if the problem is in my side, I use my usual workflow which usually works… If you found something from me is not right, please point me out… Thanks…

Hi @VirtualSpaceBackend,

It looks like FBXSDK is failing to convert this file, but I don’t believe it’s a faulty file.

I will look further and let you know.

Sorry for the trouble!

Oh, I see… the problem is probably not from my side am I correct?
Please let me know if you have any update. Thanks

Hi @VirtualSpaceBackend,

The FBX file has an external texture reference called ‘F:\PlaycanvasProjects\KLHK\Models-FinalbxoothsNoBetter.fbm\kkviz-free-3d-model-parthenocissus-tricuspidata-02-01_NORM.png’ which our tooling wasn’t handling correctly.

I have submitted a fix for this on our end, should reach prod within the next few days.

If you’d like to get this working now, you can remove that texture from the model (or embed it like the other textures) and try importing again.

Thanks so much for the repro model. Without it we couldn’t easily find and fix the issue.



You’re welcome,

by the way, do you have any idea so that it does not point to that particular texture? I’m new in blender, and that model is created by a friend of mine.

Not sure but it looks like that particular texture was not embedded into the FBX for some reason on export.

For the time being, I export without texture using better-fbx plugin in blender and import texture manually in playcanvas and found no issue.

But please let me know if you have fix your end…

Thank you

We have a fix in review that ignores external referenced textures for imports. Please bear in mind, the issue is that the FBX is referencing a non-embedded texture.

Even if we fix the issue on our end, that texture still won’t be imported because it isn’t embedded in the FBX.

This is now fixed and released in the editor: https://github.com/playcanvas/editor/releases/tag/v1.18.6

Thanks that’s awesome