[SOLVED] Image not appearing on the Model on iOS


I am having a weird issue with iOS where the image is not appearing over the model, I have created a simple project to repro the issue here:



SS on chrome (Samsung A51)

SS on iOS (Iphone X), both chrome and safari are effected:

It is appearing correct on desktop, I don’t have a Mac so I cannot obtain the logs from my iPhone, so if anyone can check the errors, that would be great.

The same thing is happening in Mac safari. No errors in the console.

I do not have an iPhone to try this, but is there a difference if use use or not Basis compression?

I also noticed the texture size is not power of two. Might be related.

Hi @Saad_Haider,

I gave it a try on an iPad 2020 and indeed I get the missing texture issue.

Are you getting any errors in the console? Does this happen when running with a WebGL1 / WebGL2 context?

I don’t have a Mac to get the logs at the moment, but as kulodo above said he doesn’t see any errors on his Mac safari, also tried with and without basis compression, running with WebGL 1 or 2 doesnt seem to help here, also tried disabling the shadows.

Making the diffuse and the normal map POT, does fix the issue


@Saad_Haider Would you be able to fork the project back to non working state so we can investigate a fix for this please? :slight_smile: If you can attach a link to this ticket, that would be awesome: https://github.com/playcanvas/engine/issues/2949

Sorry for the late reply, I was trying to find the model by couldn’t find it and had to get it from the artist again and I have it placed in this project:
Looks like the issue still happens, attached on the issue thread.

1 Like