[SOLVED] Getting halfExtents stopped working

Hi all.
The previously running script stopped working (worked a week ago). I started to figure out what’s going on. And the mistake led me to a stupor.
On line 172, I look at render, which has meshInstances. But when I look at line 173 directly, meshInstances is empty.


Hmm, that is odd.

render.meshInstances should return render._meshInstances as seen in the engine code here:

Can you share a repro project?

I added you to the team

How do I reproduce the error?

In the first line enter (LOX)
To the second (KIS)

I’m sorry I didn’t say this beforehand.

I understood what the point is. When you uncheck the preload (model), it stops working. And it’s very bad. Whether it is possible to bypass it somehow???

If you untick preload, you have to manually load the asset and wait until it’s finished and in the scene before accessing any of the data.

Well, yes, it is logical. We’ll have to work with the update function.
Thanks for the clarification. Issue resolved. I apologize for my inexperience.