[SOLVED] Error (reading ‘getGuid’) when launching my game

Every time I launch my game it pops this up and won’t load the game the only thing I changed since I lasted launch it was scripting that shouldn’t affect the loading process and I don’t know how to fix it.
Game URL: PlayCanvas | HTML5 Game Engine

TypeError: Cannot read properties of null (reading ‘getGuid’)
at SceneParser._openComponentData
at SceneParser.parse
at SceneHandler.open
at i.open
at ResourceLoader.open
at AssetRegistry.load
at AssetRegistry.add
at d
at https://launch.playcanvas.com/editor/scene/js/launch.js:1:313641
at Array.forEach ()

sorry, there are no Links because I’m new to the forums and can only put 2 links.

Actually, here is the thread: [SOLVED] Error get guid

There is an asset that you need to delete in the project (see the one highlighted)

Once you have deleted it, it should launch fine.

1 Like

Sorry, I’m way late but I did do that and it did not work it still up the same message unless I have to delete it somewhere else?

@Blackout I am just double checking you did this correctly.

To confirm you right clicked on this file and selected delete? After you delete it from the project please just refresh the browser screen. Go back to this directory and confirm it is gone. I think this very same issue happened before with the same project type. Looking at your project I see that this file is still there. After it is confirmed deleted run the launch button and see if your issue is gone.

I can’t see the same error in your launch page

Yes, I fixed the issue thanks to you guys. Thank you!

The bug fix has now been released