[SOLVED] Error in 1.57.1 - cannot access debug.js

I get this error message related to debug.js

  • the error has come quite suddenly / out of the blue (it worked on 1.57.1 yesterday).

This is due to Material warnings · Issue #4815 · playcanvas/engine · GitHub

And is fixed for 1.58.0

but I have two parallel projects which are very similar (transferred assets manually) - one works the other do not (double checked every asset)

I can reveal the projects momentarely (but warning: they are quite large ) … still looks like a material that is broken in the copying proces

[EDIT: actually both are still failing in the console with the “Deprecated” error - but an asset will not render properly in one of them … have tried all combinations of 1.57 … 1.58 and/or WebGL1.0 ; 2.0]

Do you see the error with engine 1.58 (current)

yes have also tried in Opera browser + updated Chrome [EDIT: can the “pc.StandardMaterial#lightMapVertexColor is deprecated. Use pc.StandardMaterial#lightVertexColor instead.” be a typo from developers? … I have for security deleted all ‘Lightmap’ textures in every material]

Can you copy and paste the material(s) that are giving those warnings into a new public project please for us to look at?

in case: All materials within assets, and not only in Root, are being compiled - then ‘Yes’.
Otherwise: I made a project without any active / rendered objects in the hierarchy, which did not change anything (the error was still there).
If so (all being compiled at upstart / runtime), I will find all materials and send them (there might be 50-70 in all though)

PS: I tried to launch at my laptop which gave me this:

Can you share said project for people to look at please?

The error in the screenshot (failed to compile shader, without any error in the code being mentioned) usually means the WebGL in the browser is broken. Often a reboot helps, or new graphics drivers or similar.


{before I was trying to send my reply, I tested a final time: Now, suddenly, one of my scenes work without the error - the other is still complaining - luckely the most irrelevant… @mvaligursky: I recently installed a new GPU }

[EDIT: have now rebooted and the err msg returns both places - I am still fortunate (though in some sense) as the texture that bothered me is back / now functional again … will settle this as SOLVED, but with a vary / anxious mind for future errors]

As I’ve asked before, please provide a small repro project that we can investigate with. If you can’t, then we can’t help further.

ok, get it (will do so if any more direct problems on forward)