[SOLVED] Can't get selected camera to show in viewport

Hi All,

We’re having trouble getting a selected camera to show up in our main viewports. As of Friday, this issue has started happening so I’m wondering if there’s been an update the Editor that is causing this issue.

In the past, when selecting a camera it would show up highlighted in the mini-viewport. You can click the mini-viewport to enable the camera in the main viewport if unlocked. This is no longer the case. The mini viewport doesn’t highlight or does the lock show up.

This is happening across all our projects. We even made a new account to test, but it’s happening there also.

Any ideas?

1 Like

Seems to work for me. Can you share that new project that you created to take a look at please?

I just added you. Please let me know you received the invite.

I get the camera preview in the viewport in the top left here (pixelated for privacy):

Yes, so do we. However, we can no longer make it active in the main viewport. When we click on it nothing no longer happens.

Thanks for looking into it, Yaustar. As you can see, the lock icon is also gone in your screenshot, so we cannot lock that thumbnail either to adjust our objects framing. Clicking the thumbnail selects whatever is behind it, basically.
This has been tested on different browsers and on different machines. Tim uses MacOS, I use Windows 10. So that leads us to think that the issue is in the editor itself.

I also logged into my own account and could repeat the behavior.

Ooooh, you want to lock it. Okay, yeah that’s gone. There have been some editor changes recently. @will Do you know if the feature to lock the preview image of the selected camera is something that will be coming back/be replaced by something else?

No, we do not want to lock the camera (although, that is a function we use all the time), but we noticed that this feature was gone recently, so we figured the editor was changed.

What we are trying to do is assign any other camera than the perspective camera as our main camera. We want to see through and navigate with a new camera, if you prefer (and not the default perspective one). This does not work for us since they made the editor changes.
That is a pretty important feature, as it’s the best way to set up camera angles for our scenes.

Note that only our camera named “FLYCAM” appears in the camera list as well, which compounds our issue, since we can’t use that list to assign our cameras either.


Just to be clear, you are looking for the camera to be listed in this view?

It looks like it only works if the camera is enabled (which I think has been that way for a while now). If it’s disabled, it will appear in the list but the rendered view won’t update.

Yes, I’m talking about this list. On our current project (the one Tim shared with you), only the FLYCAM camera is available from this list, no matter the state of the others (enabled or disabled). To me, it looks like the camera list is not refreshing at all when we add, delete, enable or disable cameras. This might be due to the large number of cameras we have, not sure.

But to be clear, this is only one way to select cameras, the other way (selecting camera from the hierarchy, then clicking on its thumbnail to make it the active view) does not work anymore since the editor changes.

So in the end, we have no way to look through our various cameras at the moment, which limits us severely when trying to create our scene shots.

Yep, I see it. It looks like it is limited to two cameras on that list oddly enough. I’ve tagged the PlayCanvas team so they can have some input.

Thanks for you help here.

I just want to note that the cameras not showing in the list is not the main issue for us. Until last week, we were able to click on the mini-viewport to make a camera active in the larger viewport. This is no longer the case, so is there a work around?

I’m happy to set up a video conference so we can explain further if needed.


I’m not part of the PlayCanvas team so I’m unable to actually fix the problem unfortunately.

That said, hopefully Will from the team will drop by and be able to pickup as it seems to be multiple issues in the same area.


I tried reproducing this issue by creating a scene with 4 cameras. In my test scene the cameras work as expected (all 4 are available for selection). Can you please share the problematic project with me too, so I can take a look?


@codeon I’ve got a private fork so I can send it your way. What’s your PlayCanvas user name?

There seems to be three issues. Cameras not appearing on the list, the preview viewport is missing the lock icon that it used to have and clicking on the preview viewport no longer makes the camera the active viewport.

Yes, this is exactly what is happening.

Note that both “lock icon missing” and “clicking on the preview not working” can be reproduced on a different account, different project, different computer, different browser and different OS as well.
The camera list issue only happens on projects using a large number of cameras. The list works fine on new projects with few cameras.

Thank you for your time!

It would be great if changes ( fixes, and new features ) to the editor could be tracked, in the same way that GitHub can be used to track the engine code changes.

Hi @yaustar, my username is codebon.

The issue seems to have been fixed here, I’m able to assign as viewport cameras selected cameras from their thumbnails again.

Thank you!

1 Like