[SOLVED] Can't add to hierarchy

hello tried to add some things like primitive, rigidbody or collison to the hierarchy tree in the editor , but get always this error:
in : Herbivore
I simply don’t kwow what to do?

  • is there’s a limit to tree hierarchy? ( or to a scene ?)
  • is there to much trafic at PlayCanvas? ( tryed at different times)
  • is my game getting to big? (can’t belive this :slight_smile: )
  • Did I look in the complete wrong direction?
    (Maybe somethings wrong with windows or chrome after the last update)

I’m glad for every little hint, have spend already to much time on this to give up this easy…

thanx to all

Hi @Gurki,

That’s strange, so it happens every time after reloading the editor?

I’ve forked the project to give it a try and it seems fine to add entities so far

Edit: Scratch that. I think there is a limit on the maximum depth. I check with the team
Edit2: Tried a new project and that doesn’t seem to be the issue :thinking:

tried to restart the editor,
than restart the browser and least restart the notebook,

always the same… :frowning:
crashes if I ‘copy paste’ or use the ‘add button’ in the editor

Looks like the scene is too large looking at the console error.


Going to check in with the team on this.

Chances are you are that you will have to use multiple scenes and load additively (project sample here: https://developer.playcanvas.com/en/tutorials/additive-loading-scenes/) or the (very soon) new feature of Templates to make the scene smaller and load sections in dynamically.


had multiple scenes in my last playCanvas project, but although had great troubles with the scene change after I’ve wrapped them into an app with the Monaca wrapper…
To avoid these problems this time I’ve packed everything in one huge scene :frowning:

The new template system that will be out very soon may help then. If you have used Unity, they are basically prefabs.

1 Like

There are downsides to having a large including a much longer startup time.

Out of interest what issues were you hitting when wrapping the app?

I guess it’s more of a device issue. I often gets this issue after playing launch for like 6-10 times in one of my project. I just restart my pc and it start working again :smiley: . I still don’t know why i get this issue. :confused:

Not this one :sweat_smile: That error message suggests a size issue

1 Like

just had tranlate ‘issue’ :smiley: I’ve always translate to task… for years…

new scene didn’t show up. old scene was deleted. music from the new scene started playing but it was never displayed…

Which product of Monaca did you use?

Yea, I’m working on a small netbook, so bad hardware, but thats not the problem :slight_smile:
Got a out of memory alert from time to time, but only when I did a lot of testing, and this one was solved with a simple reset.

long time ago, but I think was Cloud IDE and debugger ?
Edit: for testing it was debugger, it’s still instaled on my smartphone.

Edit2:Although tried PhoneGap, but that was even worse.

I’ve checked in with the team, the limit is 16MB of JSON for each scene.

1 Like

Thanx, wouldn’t never find out by myself…
I’ll slpit the game then and deal with those problems later :slightly_smiling_face:
I thinck I like the idea already… hope there’s no limit for the count of scenes in the end :wink: